Avero Login Issues
Incident Report for Avero
Resolved
This incident has been resolved.
Posted Nov 11, 2019 - 22:36 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 11, 2019 - 17:02 EST
Investigating
Some Avero users are still experiencing issues logging into Avero. Our engineering team is investigating and hopes to have a solution soon.
Posted Nov 11, 2019 - 15:50 EST
This incident affected: Avero (Avero (Web)).